4 reasons why you should get PHP 7

Joomla is available using 1 click install in Cloud Server cPanel and Cloud Server Webuzo. Contact us to find out our latest offers!

joomla 4 php7

With the prospect of Joomla 4 next year we would like to raise awareness on the must of upgrading to PHP 7.
Joomla 4 will require PHP 7 to run, as stated in this announcement. Most hosts already offer PHP 7 in their packages and it should be fairly easy to change your PHP version. (Hint: before you do, make sure you backup) If not, contact your host today.

Let us give you 4 reasons why you shouldn’t wait on upgrading PHP.

PHP 7 is better

Easy to say of course, but PHP 7 actually has a performance improvement that makes your website run twice as fast (compared to PHP 5) and it has a 50% better memory consumption. Of course PHP 7 is also more secure and allows you to do more as a developer.

Joomla 4 will be awesome

Joomla 4 will have huge improvements for both users and developers. A cleaned up code, a renewed framework, great new features and much more. Bootstrap 4 will be implemented in the core, there will be 2 new templates (frontend and backend), the new media manager will be loved by many.
As Joomla 4 is still in development and predicted for second half of 2018, the list of awesome features will still extend and be announced prior to the launch.

Renewed Framework

The renewed Framework (version 2.0) that comes with Joomla 4 has some major improvements. The database API will natively support prepared statements, which is a major security enhancement. Storing encrypted data will now be possible with a more modular Keychain component. Command line tools can be build better and safer thanks to the new Console component.
For a full list of features, visit the roadmap.

It’s more secure and supported

Versions older than PHP 5.6 are no longer supported for security fixes. If some big vulnerability is found in PHP 5.3, nobody is going to fix it and your site will be vulnerable. By using the latest version, you will always know that those possible problems will be taken care of, and updates will be available to you very quickly when there is one.
As PHP 7 is the latest major version, it will be supported for a long time (including the minor releases) so your Joomla 4 website will easily run up to 2025.

But, but … What if I can’t upgrade?

An important thing to remember is that Joomla 3.9 will be supported for two years after its release. This means you can run your Joomla 3 site comfortably until 2020, but you’ll miss out on all the great features and benefits of Joomla 4. But let’s be honest, if your host is not supporting PHP 7 by now, it might be good to search another hosting company.

We are firmly committed to making the next generation of Joomla the best generation and feel that embracing PHP 7 going forward will help to deliver the highest quality product for our users.
M. Babker

Joomla is available using 1 click install in Cloud Server cPanel and Cloud Server Webuzo. Contact us to find out our latest offers!

Comments are closed.

>
%d bloggers like this: