EasyApache 4 June 5 Release | cPanel Newsroom

We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on SlackDiscord, or Reddit to talk about this update and much more.

  • ea-apache24
    • EA-8508: Apache crashes with Prefork due to ‘couldn’t release the accept mutex
  • ea-nodejs10
    • ZC-5152: Remove mod_passenger requirement from ea-nodejs
  • mod_security2
    • EA-8506: Fix update to Mod_Security 2.9.3: Update is segfaulting on some servers
    • EA-8507: Mod_Security 2.9.3 update some rules fail syntax check / Segmentation fault
  • scl-php71
    • EA-8516: Update scl-php71 from v7.1.29 to v7.1.30
  • scl-php71-meta
    • EA-8516: Update scl-php71 from v7.1.29 to v7.1.30
  • scl-php72
    • EA-8514 : Update scl-php72 from v7.2.18 to v7.2.19
  • scl-php72-meta
    • EA-8514: Update scl-php72 from v7.2.18 to v7.2.19
  • scl-php73
    • EA-8515: Update scl-php73 from v7.3.5 to v7.3.6
  • scl-php73-meta
    • EA-8515: Update scl-php73 from v7.3.5 to v7.3.6

This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.

SUMMARY
cPanel, L.L.C. has updated RPMs for EasyApache 4 with PHP versions 7.1.30, 7.2.19, and 7.3.6. This release addresses vulnerabilities related to CVE-2019-11038, CVE-2019-11039, and CVE-2019-11040. We strongly encourage all PHP 7.1 users to upgrade to version 7.1.30, all PHP 7.2 users to upgrade to version 7.2.19, and all PHP 7.3 users to upgrade to version 7.3.6.

AFFECTED VERSIONS
All versions of PHP 7.1 through 7.1.29
All versions of PHP 7.2 through 7.2.18
All versions of PHP 7.3 through 7.3.5

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2019-11038 – MEDIUM
PHP 7.1.30
Fixed bug in GD module related to CVE-2019-11038

PHP 7.2.19
Fixed bug in GD module related to CVE-2019-11038

PHP 7.3.6
Fixed bug in GD module related to CVE-2019-11038

CVE-2019-11039 – MEDIUM
PHP 7.1.30
Fixed bug in iconv module related to CVE-2019-11039

PHP 7.2.19
Fixed bug in iconv module related to CVE-2019-11039

PHP 7.3.6
Fixed bug in iconv module related to CVE-2019-11039

CVE-2019-11040 – MEDIUM
PHP 7.1.30
Fixed bug in Exif module related to CVE-2019-11040

PHP 7.2.19
Fixed bug in Exif module related to CVE-2019-11040

PHP 7.3.6
Fixed bug in Exif module related to CVE-2019-11040

SOLUTION
cPanel, L.L.C. has released updated RPMs for EasyApache 4 on June 5, 2019, with updated versions of PHP versions 7.1.30, 7.2.19, and 7.3.6. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM’s Run System Update interface.

For the PGP-signed message, please see EA4-2019-6-5-CVE.signed.

REFERENCES
https://nvd.nist.gov/vuln/detail/CVE-2019-11038
https://nvd.nist.gov/vuln/detail/CVE-2019-11039
https://nvd.nist.gov/vuln/detail/CVE-2019-11040
https://www.php.net/ChangeLog-7.php

More Information

Information about all releases this year can be found in the 2019 EasyApache 4 Changelog and the EasyApache 4 Release Notes. To ensure that you receive up-to-date product news from cPanel, we encourage you to subscribe to the Product and Security updates mailing list on our website. You can also sign up for our EasyApache Development and EasyApache Production lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.

cPanel is a control panel for Web Hosting Providers available here – Cloud Server cPanel. Contact us to find out our latest offers!

Comments are closed.

>