CentOS Web Panel News

How to install SSL for tomcat on CWP – Control WebPanel Wiki

The Apache Tomcat® software is an open source implementation of the Java Servlet, JavaServer Pages, Java Expression Language and Java WebSocket technologies To install SSL to on a tomcat server, please follow the below steps.Step 1: Create AccountCWP.Admin Left Menu -> User Accounts -> New Account -> Enter domain,username and Continue Reading

CentOS Web Panel News

How to install mod_cloudflare – Control WebPanel Wiki

Based on mod_remoteip.c, this Apache extension will replace the remote_ip variable in user’s logs with the correct remote IP sent from CloudFlare. The module only performs the IP substitution for requests originating from CloudFlare IPs by default. In addition to this, the extension will also set the HTTPS environment variable Continue Reading

How to install Apache Solr

How to install Apache Solr on CWP servers Install all required packages: yum install java lsof mysql-connector-java Check for latest version here:http://ftp.carnet.hr/misc/apache/lucene/solr/ Download and Install Solr: wget http://ftp.carnet.hr/misc/apache/lucene/solr/6.6.1/solr-6.6.1.tgz tar xzf solr-6.6.1.tgz solr-6.6.1/bin/install_solr_service.sh –strip-components=2 ./install_solr_service.sh solr-6.6.1.tgz Check if the service was properly installed: service solr status Available commands: service solr {start|stop|restart|status} Continue Reading

EasyApache 18 July 2017 Maintenance Release

SUMMARYcPanel, Inc. has released updated RPMs for EasyApache 4 on July 18, 2017, with Apache version 2.4.27. This release addresses vulnerabilities related to CVE-2017-7679, CVE-2017-7668, CVE-2017-7659, CVE-2017-3169, and CVE-2017-3167. We strongly encourage all Apache 2.4 users to upgrade to version 2.4.27. AFFECTED VERSIONSAll versions of Apache 2.4 through version 2.4.25 Continue Reading

How to enable mod_suexec with Apache

How to enable mod_suexec with Apache on CentOS WebPanelThis module allows CGI scripts to run as a specified user and group. Don’t enable this module if you don’t need it as it will add additional execution time for your scripts. This module is recommend for servers having enabled cgi-script and Continue Reading

How to install mod_pagespeed

How to install Apache mod_pagespeed module on CentOS WebPanel?mod_pagespeed is an open-source Apache module created by Google to help Make the Web Faster by rewriting web pages to reduce latency and bandwidth. Installer for 64bit Systems mkdir /usr/local/src/mod_pagespeed cd /usr/local/src/mod_pagespeed wget https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_x86_64.rpm rpm2cpio mod-pagespeed-stable_current_x86_64.rpm | cpio -idmv cp /usr/local/src/mod_pagespeed/usr/lib64/httpd/modules/mod_pagespeed.so /usr/local/apache/modules/ Continue Reading

How to install mod_limits

How to install Apache mod_limits module on CentOS WebPanel?This apache module is aimed at protecting the web server during attacks. It provides a few, very usefull, functionalities: * Limit the maximum number of simultaneous connections* Limit the maximum number of simultaneous connections per Vhost* Limit the maximum number of spawned Continue Reading

EasyApache 21 February 2017 Maintenance Release

SUMMARYcPanel, Inc. has released EasyApache 3.34.12 with Apache version 2.2.32. This release addresses vulnerabilities related to CVE-2016-8743 and CVE-2016-5387. We strongly encourage all Apache 2.2 users to upgrade to version 2.2.32. AFFECTED VERSIONSAll versions of Apache 2.2 through version 2.2.31 SECURITY RATINGThe National Vulnerability Database (NIST) has given the following Continue Reading

LiteSpeed Enterprise WebServer for CWP

LiteSpeed Enterprise 30 Day Free Trial! LiteSpeed Enterprise is a high-performance Apache drop-in replacement web server, currently the 4th most popular web server on the internet and the #1 commercial web serverCompatible with commonly used Apache features, including mod_rewrite, .htaccess, and mod_security, LiteSpeed Enterprise can load Apache configuration files directly Continue Reading

EasyApache 5 January 2017 Maintenance Release

SUMMARYcPanel, Inc. has released updated RPMs for EasyApache 4 on January 5, 2017, with Apache version 2.4.25. This release addresses vulnerabilities related to CVE-2016-0736, CVE-2016-2161, CVE-2016-5387, CVE-2016-8740, and CVE-2016-8743. We strongly encourage all Apache 2.4 users to upgrade to version 2.4.25. AFFECTED VERSIONSAll versions of Apache 2.4 through version 2.4.23 Continue Reading

>